Pages

Wednesday, July 11, 2012

ccnp route ospf network types


Understanding OSPF network types

ospf nbma configuration:
R1
show ip int br
router spf 1
network 10.12.3.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
router-id 1.1.1.1

point-to-point is a default network for the loopback interface

R2:
router ospf 1
router-d 2.2.2.2
network 10.12.3.0 0.0.0.255 area 0
network 10.24.0.2 0.0.0.0. area 24
network 2.2.2.2 0.0.0.0 area 0


R2
int s0/0.1
ip ospf priority === this router is not going to be designated router
network 10.12.3.0 0.0.0.255. area 0
network 10.35.6.3 0.0.0.0 area 356
network 3.3.3.3 0.0.0.0

R5
router ospf 1
router-id 5.5.5.5 0.0.0.0 area 356

Area Types and Options:

Virtual Links: breaking the rules
Every single area must be directly connected to area 0. virtual links break up this rule. This is not a good implementation.

R2 :
show ip protocols
show ip int br
router ospf 1
router-id 2.2.2.2
network 10.1.23.1 0.0.0.0 area 1
network 10.1.1.1 0.0.0.0 area 2== here area2 is nto directly connected to area 0

Configure virtual links:
virtual links depend on router-id

R3
router ospf 1
area 1 virtual-link 2.2.2.2 === that's build a bridge between the neighbors

R2
router ospf 1
area 1 virtual-link 3.3.3.3 (router-id of router3 ie neighbor)

a virtual link is kind of tunnel which believes as if a link is directly connected.

the tunnel doesn't show up in "show ip int brief" so use "show ip int vir" instead

You can do virtual links within virtual link but its not advisable.

OSPF AReas and Router Types:
===============================
to reduce topology table entries

Link state advertisements(LSAs) are the building blocks of OSPF; many types exist

LSA TYPE 1: Router LSA
LSA TYPE 2: Network LSA (DR generated)
LSA TYPE 3: Summary LSA (ABR Summary route)
LSA TYPE 4: Summary LSA (ASBR Location)
LSA TYPE 5: External LSA (ASBR Summary routes)

STUB and Totally Stubby Areas:
=============================
Stubby area : blocks type 5 LSAs from entering that area
Totally stubby area : blocks type 3 , 4 and 5 LSAs from entering the area

Configure stub area:
R2
router ospf 1
area 2 stub

stub flag must agree between neighbors to form a relationship
R1
router ospf 1
area 2 stub

now external routes will be replaced by default router O*IA 0.0.0.0

Totally stuby area:
this type of area should block everything coming in. TSA is cisco propriety. The true device that needs to be from ciso will be ABR

In ABR
router ospf 1
area 1 stub no-summary
here too stub flag sud be same between neighbors

In neighbors router too
router ospf 1
area 1 stub (no need to give no-summary since we assume it is not cisco device)

This will save lot of processing cycle.

Not-so-stubby Areas
=====================
passes external routes through via type 7 LSAs. These convert back to Type 5 once they reach the backbone

router ospf 1
area 1 nssa
redistribute rip subnets metric 10 (sends rip routes into ospf)

In ABR
router ospf 1
area 1 nssa no-summary

ABR receives RIP as type 7 LSA but advertise them as type 5

Note: There must be only one exit point from the stubby or totally stubby area. You can have multiple for redundancy but in that case, we will have dual entries in the table which is not a good design.

ospf supports both clear text password and MD5 authentication.

int f0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco

here we can't define multiple keys like in eigrp.

authentication can be configured in int mode or area mode.

for clear text :
int s0/0
ip ospf authentication
ip ospf autheication-key cisco


if you want to set default cost for external routes use
area 23 default-cost 100

No comments:

Post a Comment